30k Supply "Forgot to register?" button not there

2 years ago

I've seen a lot of people with the problem that they didn't get a confirmation e-mail or successfully verified their e-mail but simply didn't get their supply transferred. As for me I can't register to begin with. Once in-game I open up the menu and select the Options. At that point however, unlike described by everyone, I don't get asked to register. I have no button to register in sight. Just the box with the Gameplay settings.
Here's a picture of what I see: https://steamuserimages-a.akamaihd.net/ugc/933807031691430881/78B219416EC01CD24AF8C8B86F53C05ACB061418/
I already submitted a request but after me for my Steam64ID the support stopped answering me. I've been waiting for 3 days to get a reply ever since. If someone had the same problem please report how you fixed it.


  • #2
    2 years ago
    r_fralexr_fralex Posts: 180 admin

    Hey @DaZeta - sorry you are having issues. Let us try to figure out what is happening here:

    • have you alread linked your SSO and Steam account in another Relic game (like DoWIII)? (in which case it was also done for COH2 and you wouldn't see that button)
    • have you been able to verify your email address? The reward is only granted for accounts with verified email addresses.


  • #3
    2 years ago
    DaZetaDaZeta Posts: 5

    Hello Fralex,
    First off thanks for your reply, I became pretty frustrated with the support that has been telling me theyre working on it for 2 weeks now. No I didn't link my Account in any game before. But after reading all this I just did it. However instead of doing it through CoH2 I did it through DoW3 since I have the button there. I logged in to my Account I created on the relic website(not ingame). However nothing happened. Since that account already exists there was no verification email of course but I did verify it back when I created it. Since I didn't get anything I bothered creating another gmail account and tried it with that. I created a Relic Account with that E-Mail and verified it. It said I would get my Infame Content Rewards the next time I log in but nothing happened. Is it because I used a email that isnt identical to my steam accounts?
    Best regards.

  • #4
    2 years ago
    r_fralexr_fralex Posts: 180 admin
    edited March 2018

    Hey @DaZeta - so it seems you have registered two different Relic accounts, with two different email addresses. The one you are using in-game shows it's been granted those 30K supply points. Happy to discuss it via PM if needed.

    The reason why it took some time for us / support to look into it is because the account you are using to post on the forums is not the same as the one you use in-game. It would obviously make things easier for us if you used the same account for both :)

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

  • © SEGA. SEGA, the SEGA logo, Relic Entertainment, the Relic Entertainment logo, Company of Heroes and the Company of Heroes logo are either trademarks or registered trademarks of SEGA Holdings Co., Ltd. or its affiliates. All rights reserved. SEGA is registered in the US Patent and Trademark Office. All other trademarks are the property of their respective owners.